installing latest octave on linux mint

The version of GNU Octave available in the official repositories of Linux Mint (and Ubuntu) is out-dated. I think the Mint 13 repositories have Octave 3.2.4, whereas 3.6.3 is the latest, released in September. Fortunately for those who want to avoid the time-consuming installation from source, there is a PPA where latest releases of Octave are maintained for Ubuntu versions up to 10.04 LTS. For Linux Mint 12 Lisa (based on Ubuntu 11.10) and Mint 13 Maya (based on Ubuntu 12.04 LTS), the same PPA can be used.

Details of the installation:
GNU Octave PPA (mtmiller/octave)

Open a terminal and execute the commands:

sudo add-apt-repository ppa:mtmiller/octave
sudo apt-get update
sudo apt-get install octave gnuplot

The new installation will remove older conflicting versions (if any) in the system.

At the time of writing, the latest Octave available with this PPA is 3.6.3, same as the one available at the official GNU Octave sources page.

About these ads

One thought on “installing latest octave on linux mint

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s